Photoshop CS5: Keyboard shortcut issue fixed by Mac OS X 10.6.7

Photoshop + Software Update = happy

Have you found that some keyboard shortcuts in Photoshop CS5 (Mac) haven’t been working? Or are some tools acting strangely, as if the Option or Shift keys were pressed? It turns out that Mac OS X 10.6.5 introduced a bug where modifier keys might stick; for example, you might always see the Hand tool, as if the spacebar was pressed, and you might be unable to switch away from the Hand tool. One way I experienced it was when I tried to press the Command and Spacebar keys to get the temporary Zoom tool, but nothing would happen.

The bug was also in Mac OS X 10.6.6, but Adobe reports that Apple finally fixed the problem in the Mac OS X 10.6.7 update. So while there have been various workarounds that involve tracking down software conflicts, now that Mac OS X 10.6.7 is out, the fastest and simplest solution is to download and install the Apple update. As usual, you can run Software Update to get the new version, or you can download the Combo installer from the link above.

While the problem isn’t mentioned in Apple’s release notes for 10.6.7, this issue is related to a change that Apple made to an API in Mac OS X 10.6.5, as explained in this forum post. A number of Mac applications were affected, but Photoshop was the most prominent one, and there are several threads discussing it on the Adobe User-to-User Forum for Photoshop.

Update: OpenType issues introduced with Mac OS X 10.6.7

Upgrading to 10.6.7 is no longer a no-brainer. Apple has apparently introduced a new bug related to OpenType fonts in PDF files generated by Mac OS X 10.6.7, so if you use OpenType fonts (and who wouldn’t, since they’re modern and cross-platform) you may have problems printing or rendering from them in 10.6.7. I suppose it comes down to whether it’s more important to you to have your keyboard shortcuts working in programs like Photoshop (in which case you’d upgrade to 10.6.7), or whether you need reliable handling of OpenType fonts (in which case you’d stick with 10.6.6).

(Update to this update: Apple has fixed this OpenType issue in the Snow Leopard Font Update, so make sure you run that update after updating to 10.6.7.)


  1. I upgraded to CS5 recently and this misbehaviour was beginning to bug me. Last night I happened to do a software update check and there was nothing new. Today I finally decided to get the bottom of why the shortcuts weren’t working, figuring that it was an Adobe problem. Then I came across this post. Checked Software Update again and lo and behold there’s 10.6.7 and it cures the bug. All shortcuts are behaving properly again. Hooray, and thanks for the very timely tip-off.

  2. Might have spoken too soon… Working on a 16 bit image with one curves adjustment layer. The keyboard shortcuts don’t stick but jump back to the current tool (clicking with a mouse works, of course). However if I convert to 8 bit the shortcuts work again. Flattened the image and converted back to 16 bit – shortcuts work. Very strange.

    1. I’ve been playing around with it and I thought I might have seen a little weirdness, but I couldn’t make it happen in another user account on my Mac that’s much cleaner (not as many background utilities). And in either account, I couldn’t reproduce any differences between 16-bit and 8-bit editing when a curve adjustment layer exists. I had no tool switching problems while editing in 16-bit mode.

      If you can reproduce it consistently, especially in a clean user account, with the most current Photoshop CS5 update installed, you should report it in an Adobe forum thread about this problem where Adobe employees are hanging out, like the one I linked to in the post. If something odd is still happening, they’ll want to help isolate it.

  3. Thanks for posting this but I think I have a different kind of problem with Keyboard shortcuts on the Mac. I have an iMac with the small keyboard and when I try to use any tool with a shortcut like “M” for the rectangular marquee tool; if I try to press it again fast enough to go to the Circular Marquee it doesn’t work. No matter how many times I press it nothing happens. This is the same for any other shortcut that have more than one tool to get to them. I’ve had this problem with Two Macs I owned with CS4 and CS5 even the trials of both photoshop versions have the same problem with me. Do you know what causes this or how to fix it? PLEASE let me know. I haven’t found anyone else with this problem

    1. I just tried this in Photoshop CS5 with the preferences reset to factory settings, and I see what you mean.

      By default, you’re not supposed to be able to switch tools by pressing the same key. What you’re seeing is actually the way it’s supposed to work out of the box, and this is probably why you saw it happen on any version you tried. Don’t worry, though, there are two ways to make the tool switch happen:

      A. Open Photoshop preferences, and in the General pane, deselect “Use Shift Key For Tool Switch.” Now the tool switch will work the way you expect. It’s possible that you might have learned Photoshop with this preference turned off; that might be why you expect it to work just by pressing the shortcut key again. But by default, a tool won’t switch unless you also press Shift.

      B. Leave the preference the way it is, but press Shift plus the shortcut key to switch tools.

      Personally, I like having to press Shift, because for me it’s like a “safety latch” that avoids accidental blind tool switches when I have all panels hidden. With the current default behavior, even if I’ve hidden the tools, I can be certain that a tool stays the way it is unless I press Shift.

      And by the way, it doesn’t matter how quickly you press the shortcut key. Once you’ve got it in tool switch mode, all that matters is that you press the key again. The only variation in this behavior is the new “spring-loaded” feature in Photoshop CS5 where, for example, if you currently have the Selection tool, you can use the Rectangular Marquee tool temporarily by pressing and holding it. Once you release the key, the tool springs back to the Selection tool. That difference here is that you are pressing and holding, instead of just briefly tapping the key.

  4. Wow thank you very much I feel real dumb not knowing this. Yes I had learn and got used to just switching without the Shift modifier. I can’t believe I had to struggle and be slowed by just a simple press of the Shift key… Oh man.

    Anyway I am really thankful! This made my day. Thank you so much!!

  5. PLEASE HELP! I am having the same problem as Pete, but I am running CS5.1 on OS 10.6.8! I have described the problem below:

    When I start photoshop, every time I switch from layer to layer or I switch tools using my keyboard shortcuts, it gives me the mac loading symbol (this is new). The loading symbol I am referring to is the lines that look like large clock lines, not the spinning beach ball of death. But it ultimately gets what I am trying to do, and it responds to my keyboard request.

    Then, once I have been using the program for about 3 to 4 minutes, it starts doing something different.

    When I use a keyboard shortcut to switch from one tool to another. Example: I am using the clone stamp, but I want to switch to the healing brush tool. So naturally, I hit “J” on my keyboard and the tool SHOULD switch from Clone to Healing Brush. But what happens in my case, is it will give me the loading symbol (shown above) while over on my tools panel, the selected tool switches briefly from Clone to Healing brush, then instantaneously, I get another loading symbol and it switches BACK to CLONE, without me hitting anything.

  6. I have Mac OS X 10.6.8. Using Photoshop CS5 12.0 x64 Some of the shortcuts aren’t working like Shift F5 for fill.

    1. One thing I would try is to choose Edit > Keyboard Shortcuts, and see which Set is selected. The normal keyboard shortcuts should work if the selected Set is Photoshop Defaults. If it’s set to something else, or if you see the word “(modified)” after the currently selected set, the shortcuts might have gotten changed to something you’re not familiar with. If that’s the case, try choosing Photoshop Defaults.

      1. Thanks but that didn’t work. I did find out that if I hit the delete key when a selection is made, I get the “fill” I was looking for. I’m baffled.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.